Possible Infrastructure Issues
Incident Report for PayTrace
Postmortem

We are sorry our clients had to endure this unforeseen outage. We experienced an issue with Load Balancing that mimicked an SSL Certificate error. We have resolved the issue and our servers are stabilized behind the load balancer.

Posted Mar 20, 2016 - 10:50 PDT

Resolved
This incident has been resolved.
Posted Mar 20, 2016 - 04:54 PDT
Investigating
Our automated systems are having trouble reaching our servers and we're investigating the possible connectivity issues. More information will be made available soon.
Posted Mar 20, 2016 - 04:51 PDT