PayTrace Connectivity Issues
Incident Report for PayTrace
Postmortem

What Happened?

At 4:15AM Pacific our load balancer at our primary data center ceased responding. Once this occurred, all connectivity to PayTrace virtual terminal services including our API were unreachable. After working with our provider and diagnosing the problem our load balancer was back in operation at 5:28AM Pacific.

Duration - 1 hour 13 minutes

What Caused This to Happen?

The failure was caused by the load balancer ceasing to respond and requiring a full reset. This problem was magnified by this being a single point of failure in our network.

What are We Doing to Prevent This?

PayTrace is beginning a major investment in upgrading all of our networking infrastructure and eliminating single points of failure like this. We were already in this process before this incident occurred. The timeline for these improvements will be occurring between July and September of this year.

We are also reviewing all of our currently operating equipment and identifying any potential problems that might occur before we complete our upgrade project.

Our Apologies

We strive to maintain a stable and reliable service for our customers. We are sorry for any inconvenience this outage may have caused you or your customers and we are working to continue to upgrade our services and responsiveness for you.

outage history
  • Last incident > 30 minutes was on March 20, 2016
  • Last incident > 1 hour was on August 24, 2015.
Posted Jun 02, 2016 - 11:51 PDT

Resolved
Connectivity problems to PayTrace have been addressed and are stable. Postmortem on this incident to follow.
Posted Jun 02, 2016 - 10:15 PDT
Monitoring
Connectivity is restored at the moment, and we are currently monitoring our service.
Posted Jun 02, 2016 - 05:31 PDT
Investigating
We are currently investigating possible connectivity issues to our platforms. Service may be degraded at this time.
Posted Jun 02, 2016 - 05:15 PDT