PCI Compliance TLSv1.2 - Courtesy Advisory
Incident Report for PayTrace
Resolved
TLS v1.0 & 1.1 have been switched OFF since Thursday Mar 30 07:31:37 AM PDT 2017.

We’re always happy to help. Please contact us with any questions.
Posted Apr 04, 2017 - 08:03 PDT
Update
As of Thursday Mar 30 07:31:37 AM PDT 2017 TLS v1.0 & 1.1 has been switched OFF.

We’re always happy to help. Please contact us with any questions.
Posted Mar 30, 2017 - 07:35 PDT
Update
We have Switched ON TLS v1.0 & 1.1 for a short window to provide one last opportunity for integrators to upgrade their systems.

** Thursday March 30th will be a hard deadline Switch OFF **

----------------------------------------------------------------------------------------------------
How to validate your TLS v1.2 upgrade:

If you are a Virtual Terminal user please validate your browser supports TLS v1.2, please test it by navigating to: https://beta.paytrace.com

If you have an integration with a Traditional PayTrace API, please send a test API request to the endpoint URL: Traditional API - https://beta.paytrace.com/api/default.pay
----------------------------------------------------------------------------------------------------

We’re always happy to help. Please contact us with any questions.
Posted Mar 23, 2017 - 13:34 PDT
Monitoring
PayTrace has sent a few Bulletin notifications on the TLSv1.2 security upgrade this year.
PayTrace support for TLS v1.0 & v1.1 ended back on January 17th, 2017: http://status.paytrace.com/incidents/36clc17mln77 Since then we have disabled TLSv1.0 & 1.1 on all other PayTrace endpoints.

We officially upgraded our systems for PayTrace.com today at 1:00pm PDT. If you are experiencing issues right around that time frame, you need to upgrade your operating system to a version that supports TLS v1.2.  

We’re always happy to help. Please contact us with any questions.
Posted Mar 22, 2017 - 14:32 PDT
This incident affected: Transactional Processing (Traditional) and Virtual Terminal, Traditional API & Secure Checkout, Reports - Billing | Invoicing.