Possible Performance Issues
Incident Report for PayTrace
Resolved
This incident has been resolved.
Posted Mar 04, 2016 - 03:45 PST
Investigating
Our automated systems have detected possible performance issues with our External Branded Site (paytrace.net). We're currently investigating and will provide more information soon.
Posted Mar 04, 2016 - 02:55 PST