Recurring Payments
Incident Report for PayTrace
Resolved
We have resubmitted all recurring payments. Should you have additional questions please feel free to contact our client support team.
Posted Jun 09, 2020 - 08:54 PDT
Investigating
Our team is investigating reports of recurring payments failing to process. As more information becomes available we will continue to update this page. Thank you for your patience.
Posted Jun 09, 2020 - 07:21 PDT