09/24/20 Recurring Payments/Custom Reports/Store and Forward Issue
Incident Report for PayTrace
Resolved
We were able to successfully process all 09/24/20 Recurring Payments/Custom Report and Store and Forward payments. Reports and receipts have been emailed out accordingly. We were able to identify and resolve the issue causing this incident. All Recurring Payments/Custom Report and Store and Forward payments will process at there normal scheduled time tomorrow.

Thanks,
PayTrace
Posted Sep 24, 2020 - 08:35 PDT
Identified
Our IT Team has identified the issue and are in the process of manually reprocessing Recurring Payments/Custom Reports and Store and Forward payments. We will provide an update once this has been completed.

Thanks,
PayTrace
Posted Sep 24, 2020 - 08:12 PDT
Investigating
We are currently investigating reports of 09/24/20 Recurring Payments/Custom Report and Store and Forward payments not processing. We have our IT team looking into the issue and will update this page once we have more information.
Posted Sep 24, 2020 - 07:26 PDT
This incident affected: Reports - Billing | Invoicing.