Possible Performance Issues
Incident Report for PayTrace
Postmortem

We sincerely apologize our clients had to endure this unforeseen outage around our External Branded Site (paytrace.net). Upon investigation, we discovered our 3rd party provider had an IIS Application crash.

Posted Mar 02, 2016 - 15:55 PST

Resolved
This incident has been resolved.
Posted Mar 02, 2016 - 08:04 PST
Investigating
Our automated systems have detected possible performance issues with our External Branded Site (paytrace.net). We're currently investigating and will provide more information soon.
Posted Mar 02, 2016 - 07:18 PST