Possible Performance Issues
Incident Report for PayTrace
Postmortem

Upon investigation, we discovered our 3rd party provider performed unscheduled maintenance. We sincerely apologize and have taken action to communicate our required process for maintenance windows in order to keep our clients aware of upcoming maintenance to maintain desired uptime.

Posted Feb 18, 2016 - 11:37 PST

Resolved
This incident has been resolved. Our External Branded Site (paytrace.net) is Operational, we will investigate the cause and provide a postmortem in the morning.
Posted Feb 17, 2016 - 21:05 PST
Investigating
Our automated systems have detected possible performance issues with our External Branded Site (paytrace.net). We're currently investigating and will provide more information soon.
Posted Feb 17, 2016 - 20:39 PST