Possible Performance Issues
Incident Report for PayTrace
Resolved
This incident has been resolved.
Posted Jun 12, 2017 - 14:44 PDT
Investigating
Our automated systems have detected possible performance issues with our External Branded Documentation Site (help.paytrace.com). We're currently investigating and will provide more information soon.
Posted Jun 12, 2017 - 14:32 PDT
This incident affected: Documentation.