EMV Errors
Incident Report for PayTrace
Resolved
This incident has been resolved.
Posted 9 months ago. Sep 06, 2018 - 23:51 PDT
Investigating
Our automated systems have detected possible performance issues with EMV. We're currently investigating and will provide more information soon.
Posted 9 months ago. Sep 06, 2018 - 23:51 PDT