Possible Performance Issues
Incident Report for PayTrace
Resolved
Our automated systems had detected possible performance issues with our External Branded Site (paytrace.net). The performance issues have been resolved.
Posted 14 days ago. Sep 04, 2019 - 10:52 PDT
Investigating
Our automated systems have detected possible performance issues with our External Branded Documentation Site (help.paytrace.com). We're currently investigating and will provide more information soon.
Posted 14 days ago. Sep 04, 2019 - 10:43 PDT
This incident affected: Documentation.