Possible Performance Issues
Incident Report for PayTrace
Resolved
This incident has been resolved.
Posted 10 months ago. Sep 25, 2018 - 09:13 PDT
Investigating
Our automated systems have detected possible performance issues with our External Branded Documentation Site (help.paytrace.com). We're currently investigating and will provide more information soon.
Posted 10 months ago. Sep 25, 2018 - 09:10 PDT
This incident affected: Documentation.