Site Latency
Incident Report for PayTrace
Resolved
We have stopped the negative impact causing latency. We will be investigating the root cause and will provide a postmortem when available.
Posted 7 months ago. Oct 29, 2018 - 15:08 PDT
Investigating
We are currently investigating reports of latency when accessing PayTrace. We are working on identifying the issue and bringing our site back to full speed. Please check back with the site periodically as we resolve this this issue. Additionally, you may also check our status page as we will be providing real time updates.
Posted 7 months ago. Oct 29, 2018 - 12:55 PDT
This incident affected: Virtual Terminal, Traditional API & Secure Checkout, and Branded Site.