MasterCard Processing Issue
Incident Report for PayTrace
Resolved
MasterCard has confirmed that this issue was on their end and has been resolved.  MasterCard transactions are being processed as normal.
Posted about 1 year ago. Jul 12, 2018 - 11:51 PDT
Update
MasterCard has confirmed that this issue was on their end and has been resolved.  MasterCard transactions are being processed as normal.
Posted about 1 year ago. Jul 12, 2018 - 11:50 PDT
Identified
Please be advised MasterCard is currently experiencing a transaction processing issue. This issue is impacting multiple frontends. Merchants may receive a response of “System Unavailable.”

MasterCard technicians are engaged and working to resolve this issue, at which time PayTrace will be provide additional information as it becomes available.
Posted about 1 year ago. Jul 12, 2018 - 11:41 PDT
This incident affected: Transactional Processing (Traditional).