Degraded Performance
Incident Report for PayTrace
Resolved
PayTrace’s technology team has identified the source of the connectivity issues and has restored all services. Should you have immediate questions, please contact our client support team who can be reached by emailing support@paytrace.com. Once again-thank you for your understanding.
Posted Jun 06, 2020 - 06:58 PDT
Update
Thank you for your patience while we continue to work through a few bugs relating to this morning’s migration to Amazon Web Services. Our team has all hands on deck and are continuing to work on a fix for this issue. We will continue to provide real-time updates on our status page.
Posted Jun 06, 2020 - 06:45 PDT
Identified
We are currently investigating reports of latency when accessing PayTrace. We are working on identifying the issue and bringing our site back to full speed. Please check back with the site periodically as we resolve this this issue. Additionally, you may also continue to check our status page as we will be providing real time updates.

Thanks,

PayTrace
Posted Jun 06, 2020 - 06:02 PDT
This incident affected: Transactional Processing (Traditional, EMV, Checks, PayTrace Go App) and JSON API, Virtual Terminal, Branded Site.