EMV Errors
Incident Report for PayTrace
Resolved
This incident has been resolved.
Posted 8 months ago. Sep 17, 2018 - 17:23 PDT
Investigating
Our automated systems have detected possible performance issues with EMV. We're currently investigating and will provide more information soon.
Posted 8 months ago. Sep 17, 2018 - 17:23 PDT