12/17/19 6:30pm PST First Data North Settlement Issue
Incident Report for PayTrace
Resolved
Our team can confirm that the 12/17/19 transactions have all successfully settled. The transactions were officially settled at 11:43am PST today. Due to our system originally identifying the transactions as settled on Tuesday, you will notice 2 batch reports for the same batch (One from Tuesday, and One Today). You don’t have to worry about any of the transactions being charged twice, they were only charged one time, the batch report itself is the only duplicate. Thank you for your patience as we worked through this issue.
Posted Dec 20, 2019 - 11:57 PST
Identified
During 12/17/19 (Tuesday’s)First Data North Settlement, First Data has acknowledged that an error occurred during settlement preventing the transactions from going through. First Data is correcting the issue with our team and will be submitting the transactions from the 17th for settlement this afternoon. We will update this page once the settlement process has been completed. We apologize for the inconvenience and have worked with First Data North to ensure that both sides are able to instantly identify any future settlement issues like this moving forward. This will only impact those with a settlement time of 6:30pm PST.
Posted Dec 20, 2019 - 10:00 PST
This incident affected: Processing Networks (First Data North (FDT)).