Global Settlement Delay
Incident Report for PayTrace
Resolved
PayTrace was able to identify the source of the settlement delay, and has resubmitted all pending batches for processing. If you have not already, batch reports for all settled transactions should be delivered to their standard recipients shortly.

Thank you for your patience as we worked to correct this brief delay. We apologize for any inconvenience this error might have caused.
Posted 4 months ago. Mar 12, 2019 - 11:21 PDT
Investigating
We are currently investigating a communication error causing delayed settlement for merchants on the Global processing platform.
Our team is working with Global to resubmit all impacted files. Once completed, batch reports will be generated and distributed as normal.

Thank you for your patience as we work to correct this issue.
Posted 4 months ago. Mar 12, 2019 - 07:29 PDT
This incident affected: Processing Networks (Global Payments (GBL)).