PayTrace.net Redirect Issue
Incident Report for PayTrace
Resolved
All sites are now fully accessible. https://www.paytrace.net is redirecting properly. Thank you again for your patience.
Posted 14 days ago. Sep 04, 2019 - 11:16 PDT
Investigating
We have identified an issue with some users not being able to access our production site via https://www.paytrace.net. We are currently investigating the cause of this redirect error, however users can still utilize https://www.paytrace.com to gain access to the system. Thank you for your patience as we work towards resolution. Updates will be provided as they become available.
Posted 14 days ago. Sep 04, 2019 - 11:02 PDT
This incident affected: Branded Site.