01/28/20 Recurring Payments Issue
Incident Report for PayTrace
Resolved
We were able to identify that the only PayTrace accounts impacted by Recurring Payments not processing were on the TSYS Processing Platform. All other Processing Platforms in PayTrace processed Recurring Payments on schedule. We have successfully processed all of the TSYS Processing Platform Recurring Payments this afternoon at 12:40pm PST. We apologize for the inconvenience.
Posted Jan 28, 2020 - 12:58 PST
Investigating
We are currently investigating reports of 01/28/20 Recurring Payments not processing. We have our IT team looking into the issue and will update this page once we have more information.
Posted Jan 28, 2020 - 07:39 PST
This incident affected: Reports - Billing | Invoicing.