Global Settlement Delay
Incident Report for PayTrace
Resolved
Global ended up being able to implement the necessary changes today (Sunday) and we have successfully started settling transactions. All transactions from Friday evening to Sunday will be settled tonight.

Please reach out to our support team at support@PayTrace.com if you have any further questions.

Thank you again for your patience.

PayTrace
Posted Jun 07, 2020 - 18:03 PDT
Monitoring
During PayTrace’s move to Amazon Web Services, our team identified an error while settling transactions on Global. We found the error and figured out what needed to be corrected in order for the settlements to be accepted. On our end, all of the connections to Global are in place, however, with it being the weekend, this isn’t a task that Global can correct on their end until Monday.

Global has informed our team that first thing tomorrow morning, they are going to try and push through the updates needed so the settlements from Friday evening to Sunday can get settled. As soon as we are given the green light, we will be manually settling all of the transactions from over the weekend. You will all receive batch reports and an update on our Status Page once this has been completed

We thank you for your understanding, as we make the changes necessary to ensure all settlements run smoothly going forward.

PayTrace
Posted Jun 07, 2020 - 16:06 PDT
This incident affected: Processing Networks (Global Payments (GBL)).