Performance Degradation Impacting PayTrace System

Incident Report for PayTrace

Resolved

Our engineering team has confirmed that all services are now fully operational. While AWS has not yet updated their public status page to reflect the recovery, our internal monitoring indicates that the underlying issue is completely resolved. Thank you for your patience.
Posted Sep 03, 2026 - 15:52 PDT

Investigating

Multiple PayTrace services are currently experiencing an interruption due to a widespread outage with our cloud provider, Amazon Web Services (AWS). Our engineering team is actively monitoring the situation and tracking AWS's progress toward a resolution. We will provide another update as soon as more information is available.
Posted Sep 03, 2026 - 15:06 PDT
This incident affected: Transactional Processing (Traditional, EMV, Checks, PayTrace Go App) and JSON API, Virtual Terminal, Traditional API & Secure Checkout.