04/16/20 Recurring Payments Issue
Incident Report for PayTrace
Resolved
Recurring payments from 04/16/20 have all been successfully processed.

We apologize for any inconvenience this may have caused.

PayTrace
Posted Apr 16, 2020 - 09:04 PDT
Identified
We have received notification that recurring payments scheduled to run 4/16/20 did not process. We currently have this issue escalated and our tech team is diligently working to correct it. Once resolved, recurring transactions dated for 4/16/20 will be processed and you will receive notification as you normally do when the process is complete.

We will also update our status page once the process completes.
Posted Apr 16, 2020 - 07:39 PDT
This incident affected: Reports - Billing | Invoicing.