First Data Processing Issues
Incident Report for PayTrace
Resolved
FDT is back up and running. We apologize for the inconvenience.
Posted Jan 10, 2024 - 11:21 PST
Identified
We have identified the issues that are sporadically affecting the ability to process transactions on the First Data Processing Platform. Our technology team continues to work with First Data to see what is causing the error when processing. We apologize for this issue and have all hands on deck trying to resolve this issue as quickly as possible. We will provide more updates as they become available.
Posted Jan 10, 2024 - 10:59 PST
This incident affected: Processing Networks (First Data North (FDT)).