Possible Performance Issues
Incident Report for PayTrace
Resolved
Our automated systems had detected possible performance issues with our External Branded Site (paytrace.net). The performance issues have been resolved.
Posted Oct 15, 2022 - 14:10 PDT
Investigating
Our automated systems have detected possible performance issues with our External Branded Documentation Site (help.paytrace.com). We're currently investigating and will provide more information soon.
Posted Oct 15, 2022 - 14:09 PDT
This incident affected: Documentation.