Telephone Support Unavailable
Incident Report for PayTrace
Resolved
8x8 has resolved the issue. Telephone support is now available.
Posted Feb 13, 2024 - 07:38 PST
Identified
PayTrace utilizes 8x8 as our phone provider. They have identified issues impacting the ability of agents to login, and customers to make phone calls. They have all hands on deck to get their system back up and running at full speed. While this issue gets corrected, please send all questions to support@PayTrace.com for immediate assistance. We’ll post updates when we know more.

Thank you, for your patience.
Posted Feb 13, 2024 - 07:29 PST
This incident affected: 5-Star Support.