PayTrace.net Currently Down-Login page still available

Incident Report for PayTrace

Resolved

Our DevOps team has identified and resolved the issue affecting access to the PayTrace.net website. The site is now fully operational and available for use.

We sincerely appreciate your patience and understanding throughout this matter.
Posted Mar 19, 2026 - 13:27 PDT

Identified

We have identified an issue with accessing our PayTrace.net website. However, you can still log in to PayTrace by going directly to PayTrace.com/login.pay.
We have located the issue and are working on fixing it. We will provide updates as they become available.
Posted Mar 19, 2026 - 13:07 PDT
This incident affected: Branded Site.