We have successfully resolved the issue that was impacting recurring payments. All payments that did not process previously have now been successfully processed. Thank you for your patience while we worked on this resolution.
For any further questions or concerns, please feel free to reach out to our support team.
Posted Jul 02, 2025 - 15:45 PDT
Identified
We are currently addressing an issue that has affected the processing of recurring payments for some merchants. Our team is actively working on a hot fix, and once implemented, we will re-run the missed transactions. Please refrain from processing these payments manually, as we will ensure that all missed recurring payments are identified and processed accordingly.
Thank you for your understanding and patience as we work to resolve this matter.
Posted Jul 02, 2025 - 07:12 PDT
This incident affected: Transactional Processing (Traditional).