Degraded Processing Performance
Incident Report for PayTrace
Postmortem

At 7:44am PST we were notified that transactions were unable to be processed, and that users were presented with system errors. We discovered a Windows update caused an issue with one of our servers. At 8:06am PST we rolled back the Windows update and fixed the issue impacting our server. All merchants were instantly able to process transactions without issue. Our team is now testing the Windows update to identify what in the update caused this behavior. We apologize for any impact this may have caused our merchants and if you have any additional questions, please contact our support team at support@paytrace.com or by calling (888) 806-6545.

Posted Oct 29, 2019 - 14:00 PDT

Resolved
Our team was able to identify the issue and resolve the problem. We will be updating this page with the cause soon.

Thank you again for your patience while we corrected the error.
Posted Oct 23, 2019 - 08:14 PDT
Investigating
We are currently investigating latency issues effecting the ability to navigate and utilize the PayTrace system. Our technology teams are working diligently and will provide updates as they become available. Thank you for your patience as we work to end this interruption.
Posted Oct 23, 2019 - 07:54 PDT
This incident affected: JSON API, Virtual Terminal, Traditional API & Secure Checkout, and Reports - Billing | Invoicing.