PayTrace Website Latency

Incident Report for PayTrace

Resolved

Our Technology team has resolved the issue, and our sign-in page and website are now functioning at normal speeds. Thank you for your patience and understanding!
Posted Apr 08, 2025 - 09:34 PDT

Identified

PayTrace users are experiencing website latency when logging in to our system. Our Technology team was made aware of the issue and has identified the problem. A fix will be going out momentarily. We will provide additional updates when they become available.
Posted Apr 08, 2025 - 07:46 PDT
This incident affected: Virtual Terminal and Branded Site.