Possible Performance Issues
Incident Report for PayTrace
Resolved
This incident has been resolved.
Posted May 30, 2024 - 16:04 PDT
Update
Our team has identified a DNS issue that impacted a large quantity of users from being able to login to their account. Our teams have implemented a number of changes as a result, and were able to restore service for these users. Performance has been stable for roughly 24 hours. Our teams will continue to monitor site availability closely and will communicate out if there are any further disruptions.
Sincerely,
PayTrace
Posted May 30, 2024 - 14:20 PDT
Monitoring
A fix has been implemented and we are monitoring the results. We will be publishing a post-mortem here shortly.

Thank you for your patience during this issue.

The PayTrace Team
Posted May 29, 2024 - 15:31 PDT
Update
Our teams are still investigating the root cause of this issue, and have validated that the performance of our login page is back up and running. You are now able to log in like normal. We have all hands on deck to find what caused this issue and to put in a permanent fix. Once we have done that, we will provide more information about the incident here shortly.
Posted May 29, 2024 - 14:47 PDT
Investigating
We are currently investigating a latency issue when signing into PayTrace.

We appreciate your patience as we work towards a resolution.
Posted May 29, 2024 - 13:24 PDT
This incident affected: Virtual Terminal.