First Data North Processing Platform Issue
Incident Report for PayTrace
Resolved
First Data North transaction processing is back up and running at full speed. We apologize for the inconvenience.
Posted Aug 02, 2021 - 11:43 PDT
Investigating
We are currently investigating issues affecting the ability to process transactions on the First Data North Processing Platform. Our technology teams are working with First Data to see when their network will be back up and running and to find out if there is anything we need to do on our end to restore the connection. FYI: This appears to be an outage impacting all First Data North customers at this time. We will be sure to provide updates as they become available. Thank you for your patience as we work to end this interruption.
Posted Aug 02, 2021 - 11:37 PDT
This incident affected: Processing Networks (First Data North (FDT)).