Connectivity Issues
Incident Report for PayTrace
Resolved
The connectivity issues that were affecting the ability to access the PayTrace site as well as process payments for users have been resolved. Thank you for your patience as we worked through this issue.
Posted Apr 07, 2021 - 03:48 PDT
Investigating
We are currently investigating connectivity issues that are affecting the ability to access the PayTrace site as well as process payments for users. Our tech team is working diligently to identify and resolve the issue and will update our status page, status.payrace.com, with any updates.
Posted Apr 07, 2021 - 02:06 PDT
This incident affected: JSON API, Virtual Terminal, Traditional API & Secure Checkout, and Branded Site.