PayTrace Telephone Support is currently Unavailable
Incident Report for PayTrace
Resolved
PayTrace telephone support is back up and running.

Thank you for your patience.
Posted Sep 30, 2021 - 14:29 PDT
Monitoring
PayTrace telephone support will be unavailable on Thursday, September 30th, 2021 at 7:30 am PDT due to high volume around our Payment Link. During this time, we will be responding to all voicemails and emails that have been sent to our team. Email support will be available during this time (Support@PayTrace.com).

We apologize for the inconvenience.
Posted Sep 30, 2021 - 07:39 PDT
This incident affected: 5-Star Support.