Possible Infrastructure Issues
Incident Report for PayTrace
Resolved
This incident has been resolved.
Posted Jan 27, 2016 - 22:21 PST
Investigating
Our automated systems are having trouble reaching our servers and we're investigating the possible connectivity issues. More information will be made available soon.
Posted Jan 27, 2016 - 22:17 PST