PayTrace.net currently
Incident Report for PayTrace
Resolved
This incident has been resolved. Our website is back up and running.
Posted Jul 17, 2024 - 13:55 PDT
Identified
We have identified an issue with accessing our PayTrace.net website. However, you can still log in to PayTrace by going directly to PayTrace.com/login.pay.
We have located the issue and are working on fixing it. We will provide updates as they become available.
Posted Jul 17, 2024 - 13:36 PDT
This incident affected: Branded Site.