Latency Issue
Incident Report for PayTrace
Resolved
This incident has been resolved.

Thanks,
PayTrace
Posted Jun 06, 2024 - 14:34 PDT
Identified
We have identified the issue and are actively working on a solution. Further details will follow soon. Thank you for your patience and understanding.

Sincerely,
PayTrace
Posted Jun 06, 2024 - 13:52 PDT
Investigating
We are aware of the latency issue affecting sign-ins to PayTrace and the use of the Virtual Terminal. While you can still log in and process transactions, we are working tirelessly to restore normal performance.

We appreciate your patience and understanding while we resolve this issue.
Posted Jun 06, 2024 - 13:06 PDT
This incident affected: Virtual Terminal.