Latency on Sign On Page

Incident Report for PayTrace

Resolved

Our DevOps team has fixed the issue and our sign in page is moving at normal speeds.

Thank you for your patience and understanding.
Posted Sep 12, 2024 - 12:14 PDT

Identified

PayTrace users are experiencing website latency when logging in to our system. Our Dev Ops team was made aware of the issue and has identified the problem and a fix will be going out momentarily.

We will provide additional updates when they become available.
Posted Sep 12, 2024 - 11:37 PDT
This incident affected: Documentation.