PayTrace Website Latency

Incident Report for PayTrace

Resolved

We are pleased to announce that the issue has been resolved and the PayTrace website is now back up and running at full speed. We appreciate your patience during this time. Thank you!
Posted Sep 14, 2025 - 10:13 PDT

Identified

PayTrace users are currently experiencing latency issues when logging in to our system. Our Technology team is aware of the problem and is working diligently to resolve it. We will provide additional updates as they become available.
Posted Sep 14, 2025 - 08:23 PDT
This incident affected: Virtual Terminal.