AWS Issue Impacting PayTrace Connectivity
Incident Report for PayTrace
Resolved
Our teams collaborated with AWS to implement a solution that restored connectivity in PayTrace. All systems are now operational. Thank you for your patience.

PayTrace
Posted Jul 19, 2024 - 01:37 PDT
Identified
Our team has identified an issue impacting all customers of Amazon Web Services (AWS). Our teams have all hands on deck working on a solution to bring PayTrace back online. We will provide additional updates as they become available. More information on the AWS outage can be found here: https://health.aws.amazon.com/health/status
Posted Jul 18, 2024 - 23:29 PDT
This incident affected: JSON API, Virtual Terminal, Traditional API & Secure Checkout, and Branded Site.