Possible Performance Issues

Incident Report for PayTrace

Resolved

This incident has been resolved.
Posted Jun 04, 2026 - 17:27 PDT

Investigating

Our automated systems have detected possible performance issues with our PayTrace Email server. We're currently investigating and will provide more information soon as possible. The issue is preventing Multi Factor Authentication (MFA) codes from being sent via Email as well as Receipts and Password Reset Links.
Posted Jun 04, 2026 - 16:40 PDT
This incident affected: Branded Site.