PayTrace Telephone Support Unavailable

Incident Report for PayTrace

Resolved

The incident has been resolved, and telephone support is now back up and running. Thank you for your patience!
Posted Jul 16, 2025 - 08:11 PDT

Identified

Our telephone provider is currently experiencing issues. Their team is aware of the problem and is working diligently to restore services. Please note that PayTrace telephone support is currently unavailable. However, email support remains accessible (support@paytrace.com), and we will provide updates as soon as we have more information. Thank you for your patience.
Posted Jul 16, 2025 - 07:12 PDT
This incident affected: 5-Star Support.