Performance issue affecting paytrace.net and the Virtual Terminal

Incident Report for PayTrace

Resolved

Our Technology team has resolved the issue, and our sign-in page and website are now functioning at normal speeds. Thank you for your patience and understanding.
Posted May 01, 2026 - 14:21 PDT

Identified

Our Technology team has resolved the issue, and our sign-in page and website are now functioning at normal speeds. Thank you for your patience and understanding.
Posted May 01, 2026 - 13:26 PDT

Investigating

Our systems have detected degraded performance affecting paytrace.net and the Virtual Terminal. During this time, you may experience slower than normal load times or processing delays.

Our engineering team is actively investigating the root cause and working to restore full performance as quickly as possible. We apologize for any inconvenience and will provide another update as soon as we have more information.
Posted May 01, 2026 - 12:35 PDT
This incident affected: Virtual Terminal.