First Data Processing Platform Issue
Incident Report for PayTrace
Resolved
Our technology team has fixed the issue impacting the First Data connection. You are now able to process transactions like normal.

Thank you for your patience during this issue.

PayTrace
Posted Sep 26, 2022 - 07:53 PDT
Investigating
We are currently investigating issues affecting the ability to process transactions on the First Data Processing Platform. Our technology teams are working with First Data to see what is causing the error when processing. We will be sure to provide updates as they become available.
Posted Sep 26, 2022 - 07:31 PDT
This incident affected: Processing Networks (First Data North (FDT)).