Performance Issues on PayTrace.net

Incident Report for PayTrace

Resolved

Our Technology team has resolved the issue, and our sign-in page and website are now functioning at normal speeds. Thank you for your patience and understanding.
Posted Apr 30, 2026 - 14:59 PDT

Update

We are continuing to investigate this issue and will provide more information as soon as it becomes available. Thank you for your patience.
Posted Apr 30, 2026 - 13:20 PDT

Investigating

Our systems have detected possible performance issues with our system (paytrace.net). We're currently investigating and will provide more information soon.
Posted Apr 30, 2026 - 12:27 PDT
This incident affected: Virtual Terminal.